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 Learning Management 
System Integrations

The Turning product LMS integrations allow you to save class rosters for Blackboard, WebCT, Sakai, Turning 
Technologies Online Roster, and Performance Matters. The LMS integration also allows you to post session 
scores to Blackboard, WebCT, Sakai, and Performance Matters.

Connecting to an LMS 

1 Access the Integrations window:

a If using TurningPoint for PC, click Tools > Integrations

b If using TurningPoint AnyWhere for PC, click the yellow down arrow on the bottom right of the showbar 
then click Tools > Integrations

c If using TestingPoint for PC, Open the Test Administrator, then click Tools > Integrations

d If using TurningPoint for Mac, click Tools > LMS Integrations

e If using TurningPoint AnyWhere for Mac, click Window > LMS Integrations

2 Select an LMS system in the Management System dropdown box. 

3 Enter the LMS server address.

4 Click Next or Continue.

5 Enter your Username and Password.

a. Check Remember this information to save the username and server information. The password is NOT 
saved. If you are using multiple Institutions, you will receive a pop-up asking you to select the institution. 
Click OK. Then choose your institution from the drop down and click Next.
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6 Click Next or Continue.

7 Choose a task

a Select Import Participant List to import a Participant List from the LMS.

b Select Export Grades/E-mail Student Grades to export a session and e-mail student grades for the 
class.

8 Click Next.

a If importing a participant list, continue on with the steps in Import Participant Lists from a LMS to a 

Turning product on page 2

b If exporting grades and e-mailing student grades, continue on with the steps in Export Grades/E-mail 

Student Grades from a Turning product to an LMS on page 3

Import Participant Lists from a LMS to a Turning product

 
1 Select the Course. 

2 Click Finish or Continue.

3 Name the Participant List. 

4 Select the save location.

5 Click Save.

6 Click Ok or Done.

Note If using Single Sign On, you will be asked to 
login using the form below and click next when 
finished.
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Export Grades/E-mail Student Grades from a Turning product to an LMS

• Export Results Data to a Blackboard Server on page 4.

• Export Results Data to a WebCT Server (CE 6.0, Vista 3, 4, or 8) on page 6.

• Exporting Results Data to a Sakai Server on page 8.

• Exporting Results Data to a Moodle Server on page 12.

• Export Results Data to Performance Matters on page 17.
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Blackboard

Export Results Data to a Blackboard Server

If you are using Blackboard follow the steps below to export results data. 

With Blackboard, instructors may select specific TurningPoint, TurningPoint Anywhere, or TestingPoint 
sessions to upload and then enter the name of the assignment and the maximum point value for responses.

Before You Begin
A gradebook, or similar file, should reside on the Blackboard Server. Turning products exports and saves the 
results data to this file.

To export results to a Blackboard server...

1 Connect to a Blackboard server. See Connecting to an LMS on page 1

2 Click Next or Continue.

3 Select the course and click Next or Continue.

4 Click Current Session or Other Sessions and click Next or Continue.

• If Other Sessions is selected, select session, click Open.

5 Check Add grades shown above to Blackboard gradebook.

a. If desired, check the box to not include non responders.

6 In the Create New Item box, enter the assignment name.

7 Enter the maximum value for the assignment.

To email students their grades follow steps 7 and 8. Otherwise, skip to step 12. 

8 Check E-mail individual results to students trough Blackboard if you want to email students their grades. 

9 Enter email address to be displayed on grade report sent to students. 

10 Check Include Common Message.

11 Select location of common message.
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12 Enter common message text.

13 Click Finish or Continue.

14 Click OK or Done.

Next Steps
Log into Blackboard and view the results data in the gradebook.
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WebCT

Export Results Data to a WebCT Server (CE 6.0, Vista 3, 4, or 8)

If you are using WebCT follow the steps below to export results data. 

With WebCT, instructors may select specific TurningPoint, TurningPoint Anywhere, or TestingPoint sessions 
to upload and then enter the name of the assignment and the maximum point value for responses.

Before You Begin
A gradebook, or similar file, should reside on the WebCT Server. Turning products exports and saves the 
results data to this file.

To export results to a WebCT server...

1 Connect to a WebCT server. See Connecting to an LMS on page 1

2 Click Next or Continue.

3 Select the course and click Next or Continue.

4 Click Current Session or Other Sessions and click Next or Continue.

• If Other Sessions is selected, select session, click Open.

5 Check Add grades shown above to WebCT gradebook.

a. If desired, check the box to not include non responders.

6 In the Create New Item box, enter the assignment name.

7 Enter the maximum value for the assignment.

To email students their grades follow steps 7 and 8. Otherwise, skip to step 12. 

8 Check E-mail individual results to students trough WebCT if you want to email students their grades. 

9 Enter email address to be displayed on grade report sent to students. 

10 Check Include Common Message.

11 Select location of common message.
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12 Enter common message text.

13 Click Finish or Continue.

14 Click OK or Done.

Next Steps
Log into WebCT and view the results data in the gradebook.
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Sakai

Teachers

Exporting Results Data to a Sakai Server

With Sakai, instructors may select specific Turning Product session files to upload and then enter the name of 
the assignment and the maximum point value for responses.

Before You Begin
A gradebook, or similar file, should reside on the Sakai Server. Turning products exports and saves the 
results data to this file.

To export results to a Sakai server...

1 Connect to a Sakai server. See Connecting to an LMS on page 1

2 Click Next or Continue.

3 Select the course and click Next or Continue.

4 Click Current Session or Other Sessions and click Next or Continue.

• If Other Sessions is selected, select session, click Open.

• If desired, check the box to not include non responders.

5 Check the box labeled Add grades shown above to Sakai gradebook.

6 In the Create New Item box, enter the assignment name.

7 Enter the maximum value for the assignment.
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Next Steps
Log into Sakai and view the results data in the gradebook.

Updating an Existing Item
 
To export updated results to a Sakai server...

1 Connect to a Sakai server. See Connecting to an LMS on page 1

2 Select the course and click  or NextContinue.

3 Click Current Session or Other Session.

• If Other Sessions is selected, select session, click Open.

• If desired, check the box to not include non responders.

4 Check the box labeled Add grades shown above to the gradebook.

5 Select the radio button to the left of Existing Item.

6 Select the item to be updated from the drop-down menu.

7 Click Finish or Continue.

Functions on the Sakai Site

Your Sakai website offeres a variety of custom functions for Teachers. Those functions include:

• Changing a Device ID for a Student

• Exporting the Class Roster in TurningPoint Format

• Send an E-mail to Unregistered Students

• Importing a Session File

• Changing Teacher Assistant Permissions

Changing a Device ID for a Student 
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1 Select a course with the TurningPoint tool installed.

2 Select the Turning Technologies link on the left side of the screen.

3 Select the Device IDs link if it is not already selected.

4 Select the Device ID to be changed.

5 Enter the Device ID.

6 If you wish to apply the device ID to all classes a student is enrolled in, check the box labeled All 
Courses.By default, Just this Course is selected. 

7 Click Update.

Exporting the Class Roster in TurningPoint Format

1 Select a course with the TurningPoint tool installed.

2 Select the Turning Technologies link on the left side of the screen.

3 Click Export Roster in TurningPoint Format.

Importing a Session File

1 Select a course with the TurningPoint tool installed.

2 Select the Turning Technologies link on the left side of the screen.

3 Click Import Session File.

4 Enter a name for the grade book entry.

5 Select the .txt file that was exported from TurningPoint. 
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6 Click Import Session.

Changing Teacher Assistant Permissions

Allows the administrator to select whether or not a Teaching Assistant is able to have the same access as a 
teacher

1 Select a course with the TurningPoint tool installed.

2 Select the Turning Technologies link on the left side of the screen.

3 Click Permissions.

4 Check the box to the right of Teaching Assistant.

5 Click Update.

Sakai Administrators

Administrators can perform all the functions starting in Teachers on page 8 as well as those listed below. 

Purging all Device IDs for all students in all courses
 

1 Select a course with the TurningPoint tool installed.

2 Select the Turning Technologies link on the left side of the screen.

3 Click Purge Device IDs.

4 Select the checkbox labeled “I am aware of the dangers of this operation and wish to continue”.

5 Click Purge.
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Moodle

Teachers

Exporting Results Data to a Moodle Server

If you are using Moodle follow the steps below to export results data. Instructors can export results data from 
participants to an available Moodle server and send grade reports to their students via Moodle email. 

However, with Moodle, instructors may select specific Turning Product session files to upload and then enter 
the name of the assignment and the maximum point value for responses

Before You Begin
A gradebook, or similar file, should reside on the Moodle Server. TurningPoint exports and saves the results 
data to this file.

To export results to a Moodle server...

1 Connect to a Moodle server. See Connecting to an LMS on page 1

2 Select the course and click Next or Continue.

3 Click Current Session or Other Sessions.

• If Other Sessions is selected, select session, click Open.

• If desired, check the box to not include non responders.

4 Check Add grades shown above to Moodle gradebook.

5 In the Create New Item box, enter the assignment name.

6 Enter the maximum value for the assignment.

To e-mail students their grades follow steps 7 and 8. Otherwise, skip to step 9. 

7 Click Finish or Continue.
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Next Steps
You can now log into Moodle and view the results data in your gradebook.

Updating an Existing Item
 
To export updated results to a Moodle server...

1 Connect to a Moodle server. See Connecting to an LMS on page 1

2 Select the course and click Next or Continue.

3 Click Current Session or Other Session.

• If Other Sessions is selected, select session, click Open.

• If desired, check the box to not include non responders.

4 Check Add grades shown above to the gradebook.

5 Select the radio button labeled Existing Item.

6 Select the item to be updated from the dropdown menu.

7 Click Finish or Continue.
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Functions on the Moodle Site
Your Moodle website offeres a variety of custom functions for Teachers. Those functions include:

• Changing a Device ID for a student

• Exporting Roster in TurningPoint Format

• Sending an E-mail to Unregistered Students

• Importing a Session File

If the TurningTechnologies block isn’t visible on the right hand side of the page, click Turn editing on then 
select TurningTechnologies from the Blocks dropdown list. Click Turn editing off once you are complete.

Changing a Device ID for a student 

1 Click Administer TurningTechnologies on the right side of the screen.

2 Select the Device IDs link if not already selected.

3 Select the Device ID to be changed.

4 Enter the Device ID.

5 Click Update.

Exporting Roster in TurningPoint Format

1 Click Administer TurningTechnologies on the right side of the screen.

2 Select the Device IDs link if not already selected.

3 Click Export Roster in TurningPoint Format.
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Importing a Session File

1 Click Administer TurningTechnologies on the right side of the screen.

2 Click Import Session File.

3 Enter a name for the grade book entry.

4 Select the .txt file that was exported from TurningPoint. 

5 Click Import Session.

Purging All Device IDs for All Students in All Courses
 

1 Click Administer TurningTechnologies on the right side of the screen.

2 Click Purge Device IDs.

3 Select the checkbox labeled “I am aware of the dangers of this operation and wish to continue”.

4 Click Purge.

Moodle Administrators

Administrators can perform all the functions starting in Teachers on page 12 as well as those listed below. 
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Configuring the TurningTechnologies Module Options
 

1 Select a Modules then Activities then TurningTechnologies from the Site Administration tree on the left 
hand side of the screen. 

2 Select the Turning Technologies link on the left side of the screen.

• Set the Device ID Format to either Hexadecimal or Alphanumeric. Hexadecimal is set by default. 

• Edit the default Reminder E-mail Subject line. 

• Edit the default Reminder E-mail body paragraph. 

• Edit the default ResponseWare URL. 

3 Click Save Changes. 
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Performance Matters

Export Results Data to Performance Matters

Before You Begin
A gradebook, or similar file, should reside on Performance Matters. TurningPoint exports and saves the 
results data to this file.

To export results to a Performance Matters server...

1 Connect to a Performance Matters server. See Connecting to an LMS on page 1

2 Click Next or Continue.

3 Select the course and click Next or Continue.

4 Click Current Session or Other Sessions and click Next or Continue.

• If Other Sessions is selected, select session, click Open.

5 Check Export Test Data to Performance Matters.

6 In the New Test box, enter the test name.

7 Enter the maximum value for the test.

8 Click Finish or Continue.

9 Click OK or Done.

Next Steps
Results can be viewed the day after they are entered into your grade book.



Turning Technologies
LMS User Guide  18 

Contact Us
Turning Technologies Customer Service Department offers first class technical support second to none. 

Technical Support is available Monday - Friday, 7am - 9pm EST. 

From within the continental United States, you can reach Customer Service toll-free by calling 1.877.726.4602. If calling 
from outside the United States, please call +(1) 330 746 3015. 

Customer Service may also be reached via e-mail at support@turningtechnologies.com. Please note, it may take up to 2 
business days for a reply if contacted via e-mail.
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